TEP 96 ou autre pour diagnostic

Forum dédié aux scooters électriques Peugeot: Scoot'elec et eVivacity

Modérateurs : Remdo, man3515, moulino51

claudegu
Messages : 166
Enregistré le : lun. 25 08 , 2008 20:00
Mes véhicules : MIA 12kW carbone
Localisation : FR-37-azay le rideau /

Message par claudegu » dim. 06 09 , 2009 16:44

Je déterre!!!

Est-ce que tu as pu progresser et savoir si la liaison TEP est bien OBD et ses paramètres ?

Claude
L'âge de pierre de s'est pas arrêté par manque de pierres
www.helica.info

pdelagrange
Messages : 3064
Enregistré le : jeu. 30 03 , 2006 11:11
Localisation : FR-35-RENNES / Clio elec, Kangoo Electri'cité, 5 Scoot'elec en panne, 1 Scoot'elec ok

Message par pdelagrange » mar. 08 09 , 2009 15:43

Nope. Je n'ai pas de TEP96 et je traiterai en priorité l'émulation XR25 (pour la clio).
Mais je suis convaincu que c'est de l'OBD (mais peut-être pas OBD-II, hein, donc laisse tomber l'ELM323, faut juste une interface RS-232 vers OBD ligne K). On verra bien quand j'essaierai.

claudegu
Messages : 166
Enregistré le : lun. 25 08 , 2008 20:00
Mes véhicules : MIA 12kW carbone
Localisation : FR-37-azay le rideau /

Message par claudegu » lun. 14 09 , 2009 12:20

Mince, j'avais justement un boitier OBD qui fonctionne sur ma voiture à base de ce composant et je me disais que j'essaierai bien sur le scootelec, mais si tu l'as déjà fait sans succès, ce n'est pas la peine.
L'âge de pierre de s'est pas arrêté par manque de pierres
www.helica.info

claudegu
Messages : 166
Enregistré le : lun. 25 08 , 2008 20:00
Mes véhicules : MIA 12kW carbone
Localisation : FR-37-azay le rideau /

Message par claudegu » mar. 15 09 , 2009 14:59

J'ai un TEP sous la main, qu'est ce qu'il faut que je fasse pour pouvoir faire avancer le schmilblic et savoir comment fonctionne cette transmission?
Je dispose d'un simple oscilloscope, sans mémoire.
L'âge de pierre de s'est pas arrêté par manque de pierres
www.helica.info

pdelagrange
Messages : 3064
Enregistré le : jeu. 30 03 , 2006 11:11
Localisation : FR-35-RENNES / Clio elec, Kangoo Electri'cité, 5 Scoot'elec en panne, 1 Scoot'elec ok

Message par pdelagrange » mer. 16 09 , 2009 23:39

Déjà, le brochage (enfin bon, on l'a déjà avec le shéma électrique): quelle est la broche où il y a du signal; à quoi ressemble le signal?

Normalement, au début on a un échange à vitesse très lente (quelques bauds), puis ça monte à 10500 bauds. Tu peux déjà vérifier ça, et vérifier aussi les niveaux de tension et tout.
Après, il faudrait observer les échanges avec un terminal série sur pc (genre teraterm mais en binaire). Le logiciel DTT2000 de Renault devrait permettre ça aussi mais je ne maîtrise pas.
Pour ça il faut une interface obd/série (ou usb); ça existe et c'est pas cher du tout (j'ai acheté la mienne sur Virtual Village, c'est un truc à base de bridge usb/série FTDI).

Une fois qu'on a débroussaillé les quelques premiers échanges il faut se faire un soft dédié pour tracer tout le reste sinon c'est ingérable.
Si c'est bien de l'ODB il existe des docs qui permettent d'aider à comprendre tout ça.

claudegu
Messages : 166
Enregistré le : lun. 25 08 , 2008 20:00
Mes véhicules : MIA 12kW carbone
Localisation : FR-37-azay le rideau /

Message par claudegu » jeu. 17 09 , 2009 9:14

Au niveau de fils :
vert : 0v
rouge : 18V
marron : signal

TEP non raccordé, contact non mis : tension sur la ligne 0V
Raccordement du TEP : 5 créneaux en moins de 2 secondes, c'est bien la trame de début de l'OBD, mais la tension n'est pas de 12V , elle est de 18V sur la ligne. C'est peut-être la raison du non fonctionnement de ton boitier OBD.
Ensuite, tant que le contact n'est pas mis, toutes les secondes environ, un code passe sur la ligne, comme mon oscillo n'a pas de mémoire, difficile à lire, mais grosso modo, les 1 et 0 ont l'air de s'alterner, ça pourrait être 55h, le code de démarrage d'une ligne OBD.
Dès que l'on met le contact, c'est un flot ininterrompu. La seule chose que je puisse voir est la durée approximative d'un bit, elle semble d'environ 0.1mS, ce qui donnerait 10kB/S peut-être bien du 9600 bauds. Attention, mes mesures sont très approximatives car je ne peux pas "bloquer le signal"

Si l'on coupe le contact, la liaison continue d'être active, si en plus on retire le TEP puis qu'on le reconnecte rapidement, la liaison reprend, si on attend, il recommence la séquence d'initialisation.

Pour moi, aucun doute, c'est de l'OBD, si tu peux essayer ton boitier en montant le signal à 18V....
L'âge de pierre de s'est pas arrêté par manque de pierres
www.helica.info

pdelagrange
Messages : 3064
Enregistré le : jeu. 30 03 , 2006 11:11
Localisation : FR-35-RENNES / Clio elec, Kangoo Electri'cité, 5 Scoot'elec en panne, 1 Scoot'elec ok

Message par pdelagrange » jeu. 17 09 , 2009 18:33

Ok, ça a l'air conforme. Le 18V n'est pas un problème.

Tu peux brancher un pc là-dessus? Soit tu achète un bridge USB/OBD, soit il y a un petit montage à faire mais ça peut être très simple. Motivé?

claudegu
Messages : 166
Enregistré le : lun. 25 08 , 2008 20:00
Mes véhicules : MIA 12kW carbone
Localisation : FR-37-azay le rideau /

Message par claudegu » jeu. 17 09 , 2009 18:53

Tu as des référence de bridge?
Quel soft derrière ?
L'âge de pierre de s'est pas arrêté par manque de pierres
www.helica.info

pdelagrange
Messages : 3064
Enregistré le : jeu. 30 03 , 2006 11:11
Localisation : FR-35-RENNES / Clio elec, Kangoo Electri'cité, 5 Scoot'elec en panne, 1 Scoot'elec ok

Message par pdelagrange » lun. 21 09 , 2009 2:23

claudegu a écrit :Tu as des référence de bridge?
ça, ça va le faire.
claudegu a écrit :Quel soft derrière ?
Ben ça faudra que je m'y colle. Sinon tu peux déjà prendre un TeraTerminal + portmon (ou bien faire un dump binaire dans tterm et regarder le résultat avec un éditeur hexa).

Une toute autre solution consiste à faire une petite interface avec l'entrée "ligne" de ta carte son (un pont diviseur fera l'affaire) et faire un enregistrement (en mono/20Hz/8 bit)... c'est très efficace comme technique. J'ai déjà pratiqué pour analyser le signal d'une manette de jeu sans fil.

claudegu
Messages : 166
Enregistré le : lun. 25 08 , 2008 20:00
Mes véhicules : MIA 12kW carbone
Localisation : FR-37-azay le rideau /

Message par claudegu » ven. 25 09 , 2009 20:38

J'aime bien la solution "carte son". Je vais commencer par là.
L'âge de pierre de s'est pas arrêté par manque de pierres
www.helica.info

Avatar du membre
Remdo
Modérateur des Forums
Modérateur des Forums
Messages : 7613
Enregistré le : mer. 08 09 , 2004 7:30
Mes véhicules : 1 e-vivacity 2013 + 6 Scoot'elec 1998 à 2002
Localisation : FR-94-Paris

Message par Remdo » lun. 28 09 , 2009 9:51

Udos vient de m'envoyer un lien qui peut être intéressant, mais faut parler italien, qu'en pensez vous ?
Remdo
« Un homme qui n’est pas informé est un sujet, un homme informé est un citoyen » -
BiblioTech scoot'elec

claudegu
Messages : 166
Enregistré le : lun. 25 08 , 2008 20:00
Mes véhicules : MIA 12kW carbone
Localisation : FR-37-azay le rideau /

Message par claudegu » lun. 28 09 , 2009 10:11

Ben, c'est le numéro de septembre 2009, en vente dans toutes les bonnes librairies et en français.... :wink:
L'âge de pierre de s'est pas arrêté par manque de pierres
www.helica.info

Avatar du membre
Remdo
Modérateur des Forums
Modérateur des Forums
Messages : 7613
Enregistré le : mer. 08 09 , 2004 7:30
Mes véhicules : 1 e-vivacity 2013 + 6 Scoot'elec 1998 à 2002
Localisation : FR-94-Paris

Message par Remdo » lun. 28 09 , 2009 10:21

Voilà l'offre [http://www.elektor.fr/magazines/2009/se ... 4959.lynkx]en français[/url] :wink:
Remdo
« Un homme qui n’est pas informé est un sujet, un homme informé est un citoyen » -
BiblioTech scoot'elec

pdelagrange
Messages : 3064
Enregistré le : jeu. 30 03 , 2006 11:11
Localisation : FR-35-RENNES / Clio elec, Kangoo Electri'cité, 5 Scoot'elec en panne, 1 Scoot'elec ok

Message par pdelagrange » lun. 28 09 , 2009 16:48

Les analyseurs OBD2 on en trouve à la pelle, même en gratuit. On trouve même le code source d'un clone du ELM323.
Sauf que ISO9141 n'est pas synonyme de OBD et encore moins de OBD2 ou EOBD.
C'est compatible électriquement et le format de données/protocole de base est le même, mais pas le reste. En particulier, ça ne va pas nous donner le format du message qui permet de lire la valeur du courant batterie, par exemple.

claudegu, je suis intéressé par les premières captures que tu pourras faire, et je travaille en parallèle à un soft espion.

claudegu
Messages : 166
Enregistré le : lun. 25 08 , 2008 20:00
Mes véhicules : MIA 12kW carbone
Localisation : FR-37-azay le rideau /

Message par claudegu » lun. 28 09 , 2009 17:34

Je récupère le TEP demain, j'ai fabriqué un adaptateur avec pont diviseur et résistance série au cas où, le tout muni d'un jack pour aller sur le PC, j'ai le soft Audacity (gratuit) qui permet d'échantillonner à la vitesse voulue.
Avec ça je devrais voir le message que le TEP envoie tant que le contact n'est pas mis. Je verrais si la suite et lisible de cette façon; il n'y a pas de raison.


En principe demain soir ou jeudi matin
L'âge de pierre de s'est pas arrêté par manque de pierres
www.helica.info

Répondre

Retourner vers « Peugeot scooters »